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Microsoft Visual Basic 2010 
Creating an Application: 



Introduction 

y Visual Studio® 2010 is Microsoft’s integrated 
development environment (IDE) for 
creating, running and debugging apps written in 
various .NET programming languages.  

y This Lecture overviews the Visual Studio 2010 
IDE and shows how to create a simple Visual 
Basic app by dragging and dropping predefined 
building blocks into place—a technique known 
as visual app development. 
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y There are several versions of Visual Studio.  
y The examples in this lecture are based on the 

Microsoft Visual Basic 2010 Express.  
y Microsoft also offers a full version of Visual 

Studio 2010, which includes support for 
Visual Basic and other languages, such as 
Visual C# and Visual C++.  

y To start Microsoft Visual Basic 2010 Express 
Edition, select Start > All Programs > Microsoft 
Visual Studio 2010 Express > Microsoft Visual 
Basic 2010 Express. 

2.2 Overview of the Visual Basic 
2010 Express Edition IDE  
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■Once the Express Edition begins 
execution, the Start Page 
displays (Fig. 2.3).  

■The Start Page contains a list of 
links to Visual Basic 2010 IDE 
resources and web-based 
resources. 

2.2 Overview of the Visual Basic 
2010 Express Edition IDE (Cont.)  



6 



7 

■ You can also browse the web from the IDE by 
selecting View > Other Windows > 
Web Browser or by typing <Ctrl> 
<Alt> R.  

■ To request a web page, type its URL into the 
location bar (Fig. 2.4) and press the Enter 
key—your computer, of course, must be 
connected to the Internet.  

■ The web page that you wish to view appears 
in the web browser tab in the IDE (Fig. 2.4).  

2.2 Overview of the Visual Basic 
2010 Express Edition IDE (Cont.)  



8 



9 

yVisual Basic organizes applications 
into projects and solutions. 

yA project is a group of related files, 
such as the Visual Basic code and 
any images that might make up an 
app.  

yA solution may contain one or 
more projects. 

2.3 Creating a Project for the 
Welcome App 
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Solutions, Projects, and Files (cont'd.) 
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y There are several ways to create a new project or 
open an existing one: 

◦ Select either File > New Project… to create a 
new project or File > Open Project… to open 
an existing project.  

◦ From the Start Page, above the Recent 
Projects section, you can also click the links 
New Project… or Open Project….  

◦ Click either the New Project Button (Fig. 2.5), 
causing the New Project dialog to display (Fig. 
2.6), or the Open File Button (Fig. 2.5) which 
displays the Open File dialog.  

Creating a Project for the 
Welcome App 
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Visual Studio 2010 (cont'd.) 

y Application: program or suite of programs 
y Windows-based application:   

◦ Has a Windows user interface  
◦ Runs on a personal computer 

y User interface: what the user sees and 
interacts with when using an application 

y Web-based application:  
◦ Has a Web user interface  
◦ Runs on a server 
◦ Accessed with a computer browser 



14 

■ Visual Basic provides several templates (Fig. 2.6).  
■ Templates are the project types you can create in Visual Basic.  
■ Select Windows Forms Application.  
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Creating a Project for the 
Welcome App (Cont.) 

■ To rename the project, type ASimpleApp in the Name: TextBox. 
Then click OK.  

 

■ Save this project in your C:\SimplyVB2010 directory. 
 

■ If you want to change the project’s location, select File > Save All 
(Fig. 2.7).  
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Creating a Project for the Welcome App (Cont.) 
■ This displays the IDE in Design view (Fig. 2.9), which enables you to 

design GUIs.  
■ The IDE’s Design view is also known as the Windows Forms 

Designer. 
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Creating a Project for the 
Welcome App (Cont.) 

■ The rectangle in the Design area titled 
Form1 (called a Form) represents the 
main window of the app you’re creating.  

■ Visual Basic apps can have multiple 
Forms—however, most apps you’ll create  
will use only one.  

■ You’ll learn how to customize the Form by 
adding GUI controls—in this example, 
you’ll add a Label and a PictureBox.  
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Creating a Project for the 
Welcome App (Cont.) 

■ A Label typically contains descriptive text (for 
example, "Welcome to Visual Basic!"), 
and a PictureBox displays an image, (select 
your preferable Image).  

■ Visual Basic Express has many preexisting 
controls and other components you can use to 
build and customize your apps. Many of these 
controls are discussed and used throughout this 
course.  

■ Other controls are available from third parties. 
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2.4 Menu Bar and Toolbar 

■ Commands for managing the IDE and for 
developing, maintaining and executing apps are 
contained in menus, which are located on the 
menu bar of the IDE (Fig. 2.12).  
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2.4 Menu Bar and Toolbar (Cont.) 

■Menus contain groups of related 
commands (also called menu items) 
that, when selected ,cause the IDE 
to perform specific actions (for 
example, open a window, save a file, 
print a file and execute an app).  
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2.4 Menu Bar and Toolbar (Cont.) 

■ You can access many common commands 
from the IDE toolbar (Fig. 2.14), which 
contains graphics, called icons, that 
graphically represent commands.  

■ By default, the standard toolbar is displayed 
when you run Visual Studio for the first 
time—it contains icons for the most 
commonly used commands, such as 
opening a file, adding an item to a project, 
saving files and running apps (Fig. 2.14).  
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■ You can customize the IDE’s toolbars.  
■ Select View > Toolbars (Fig. 2.15).  

2.4 Menu Bar and Toolbar (Cont.) 
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■ Visual Studio provides a space-saving feature called auto-hide. 
■ When auto-hide is enabled, a tab appears along either the left, 

right or bottom edge of the IDE window (Fig. 2.19).  
■ This tab contains one or more icons, each of which identifies a 

hidden window.  
■ Placing the mouse pointer over one of these icons displays 

that window (Fig. 2.20).  
■ Moving the mouse pointer outside the window’s area hides 

the window.  
■ To “pin down” a window (that is, to disable auto-hide and keep 

the window open), click the pin icon.  
■ When auto-hide is enabled, the pin icon is horizontal (Fig. 

2.20)—when a window is “pinned down,” the pin icon is 
vertical (Fig. 2.21). 

2.5 Navigating the Visual Studio IDE;  
Auto-Hide (Cont.) 
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Solution Explorer 
■ The Solution Explorer window (Fig. 2.22) provides access 

to all of a solution’s files. 
■ If the window is not shown in the IDE, click the Solution 

Explorer icon in the IDE (Fig. 2.18), select View > Other 
Windows >Solution Explorer or type <Ctrl> <Alt> L.  

2.5 Navigating the Visual Studio IDE;  
Auto-Hide (Cont.) 

■ Click the Show All Files icon (Fig. 2.22) to display all 
the files in the solution.  

■ For your single-project solution, Welcome is the only 
project. The Form file is named Form1.vb.  
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2.5 Navigating the Visual Studio IDE;  
Auto-Hide (Cont.) 

Toolbox 
■ The Toolbox (View > Other Windows > Toolbox) 

contains icons representing controls used to 
customize Forms (Fig. 2.24).  

■ With visual app development, you can “drag and 
drop” controls onto the Form and the IDE will write 
the code that creates the controls for you.  

■ Reusing preexisting controls saves time and money 
when you develop apps.  



33 



34 

Properties Window 
■ To display the Properties window, select View > Other 

Windows > Properties Window, click the Properties 
window toolbar icon shown in Fig. 2.18, or press the F4 
key.  

■ The Properties window displays the properties for the 
currently selected Form (Fig. 2.25), control or file in 
Design view.  

■ Properties specify information about the Form or control, 
such as its size, color and position.  

 

2.5 Navigating the Visual Studio IDE; (Cont.) 
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■ Figure 2.25 shows Form1’s Properties window.  
■ The left column lists the Form’s properties—the right column 

displays the current value of each property.  
■ You can sort the properties either alphabetically (by clicking 

the Alphabetical icon) or categorically (by clicking the 
Categorized icon) according to their use (that is, 
Appearance, Behavior, Design, etc.).  

■ Depending on the size of the Properties window, some of the 
properties may be hidden from view on the screen.  

■ Users can scroll through the list of properties by dragging the 
scrollbox up or down inside the scrollbar, or by clicking the 
arrows at the top and bottom of the scrollbar.  

Navigating a Project with the 
Solution Explorer (Cont.) 
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The Label Control 

y Label control: 
◦ Displays text that user cannot edit 
◦ Used as “prompts” to explain controls or display 

output 
◦ Name should end with “Label” 

y Control names use camel case 
y Camel case: lowercase first word; uppercase 

first letter of each subsequent word in the 
name 

y Not necessary to assign meaningful names for 
labels used as prompts because they are 
never used in code 

y Labels used for output should have meaningful 
names 
 



The Picture Box Control 

y Picture box control: used to display an 
image on a form 

y Image property: specifies the image to 
display 

y SizeMode property: handles how the 
image will be displayed 
◦ Settings: Normal, StretchImage, AutoSize, 
CenterImage, or Zoom 
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The Code Editor Window  
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Figure 21: Code template for the exitButton’s Click event 
procedure 
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The Close() Instruction 

y Close() instruction: closes the current 
form at run time 
◦ If the current form is the only form, the 
application is terminated 

y Method: predefined VB procedure that 
can be invoked (called) when needed 
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The Close() Instruction (cont'd.) 

The  Close() instruction entered in the Click event procedure 
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■ The Properties window is crucial to visual app 
development—it allows you to modify a control’s 
properties visually, without writing code.  

■ At the top of the Properties window is the 
component selection drop-down list, which 
allows you to select the Form or control to display 
its properties in the Properties window (Fig. 2.25). 

Navigating a Project with the 
Solution Explorer (Cont.) 
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Starting and Ending an Application (cont'd.) 

 How to start an application 
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■ Microsoft provides extensive help documentation 
via the Help menu.  
■ Using Help is an excellent way to get information 
quickly about Visual Studio, Visual Basic and more. 
Context-Sensitive Help 
■ Visual Studio provides context-sensitive help 
pertaining to the “current content” (that is, the items 
around the location of the mouse cursor).  

2.6 Using Help 
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■  To use context-sensitive help, click an item, such 
as the Form, then press the F1 key.  
■ The help documentation is displayed in a web 
browser window.  
■ To return to the IDE, either close the browser 
window or select the icon for the IDE in your 
Windows task bar.  
■ Figure 2.26 shows the help page for a Form’s 
Text property.  

2.6 Using Help (Cont.) 
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Once you’re finished with a project, you should 
save the project’s files and close the project. 
■ Before closing the project for the Welcome 
 app, you should save its files, ensuring 
 that any changes made to the project are not lost. 
■ Although you did not make any changes, save 
 your project files by selecting File > Save All. 
■ Select File > Close Project.  

2.7 Saving and Closing Projects 
in Visual Basic 



Homework
(Calculator GUI) Create the GUI for the calculator shown in the figure

Chapter 3 Welcome App 3

3.11 (Calculator GUI) Create the GUI for the calculator shown in Fig. 3.30. 

Figure 3.30  Calculator GUI.

a) Creating a new project. Create a new Windows Forms Application named
Calculator.

b) Renaming the Form file. Name the Form file Calculator.vb.

c) Manipulating the Form’s properties. Change the Text property of the Form to Cal-
culator. Change the Font property to 9pt Segoe UI. Change the Size property of
the Form to 272, 204. Note that Visual Studio resizes a Form when you change its font
size. Be sure to set the font size before setting the Form’s size.

d) Adding a TextBox to the Form. Add a TextBox control by double clicking it in the
Toolbox. A TextBox control is used to enter input into apps. Set the TextBox’s Text
property in the Properties window to 0. Change the Size property to 240, 23. Set the
TextAlign property to Right; this right aligns text displayed in the TextBox. Finally,
set the TextBox’s Location property to 8, 16—this property specifies where the
upper-left corner of the control is placed on the form.

e) Adding the first Panel to the Form. Panel controls are used to group other controls.
Double click the Panel icon ( ) in the Toolbox under the Container category
to add a Panel to the Form. Change the Panel’s BorderStyle property to Fixed3D
to make the inside of the Panel appear recessed. Change the Size property to 88,
112. Finally, set the Location property to 8, 48. This Panel contains the calculator’s
numeric keys.

Button

Panel
(contains 6 Buttons)

Panel
(contains 2 Buttons)

Decimal point Button

 Subtraction ButtonTextBox

Panel (contains 11 Buttons
for the numeric keys)


